Adobe released a security update related a critical vulnerability of arbitrary code execution by attacker if exploitation is successful. Update your Magento 2 store to keep it secure. It has been found that this exploitation could affect Magento version 2.4.5 and earlier version (including 2.4.4-p1 and earlier version). Official news of the patch can be found here.
It is recommended to update your store to 2.4.4-p2 or 2.4.5-p1 as the older version Magento 2.3 or older is no longer supported.
Release notes of Magento 2.4.4-p2 and 2.4.5-p1 can be found in this link:
Please take a look at this post on How to Install Magento 2 Quality Patches